I see a lot of developers writing tests with the "should" naming convention e.g.
describe('Searching for a thing', function() {
it('should return a result', function() {
// test
});
});
Which I understand is supposed to make the result more readable as:
Searching for a thing should return a result
Does anyone else find all the 'should's superfluous and annoying? Should we really be should'ing all over our tests? Wouldn't it be just as readable as:
Searching for a thing returns a result
Aucun commentaire:
Enregistrer un commentaire